Функция ВПР в Excel

Добрый день!

Печально взглянув на то, как мой сайт превращается в самоучитель Excel, я тоже решил принять в этом участие.

Прилетела ко мне задачка, есть две таблицы excel с перечнем фамилий, в каждой более 3 тысяч строк. Первая содержит перечень за 2008 год, вторая за 2010 год.

Задача как сделать выборку в excel фамилий, которые из перечня 2010 года вошли в перечень 2008 года.

Функция ВПР в Excel легко с ней справилась. Если у вас английская версия Excel, в ней функция называется VLOOKUP. Может быть, кому-нибудь пригодится, поэтому ниже подробный пример использования функции ВПР для решения этой задачи в Excel с картинкой.

Решается приблизительно так:

Функция ВПР в Excel

функция впр в excel пример картинка

=ВПР(C4;$A$2:$A$5;1;0)

В данном случае ВПР ищет значение Ci в колонке A диапазон $A$2:$A$5 и возвращает значение в той же строке колонки D таблицы.

Подробно на синтаксисе функции останавливаться не буду, он подробно расписан в справке Excel. Достаточно нажать F1 и в поиске набрать ВПР. В – «вертикальный» используется, если значения для сравнения находятся в колонке слева от искомых данных, иначе используем ГПР.

Ну вот, вкратце и все.





Вы можете прочитать комментарии к этой записи в формате RSS 2.0. Вы можете оставить комментарий или обратную ссылку с вашего сайта.

2 Comments к записи “Функция ВПР в Excel”

  • Ольга
    26 Мар 2012, 15:26 г.

    Не могу разобраться, подскажите пожалуйста можно ли в эксель напечатать только заполненные колонки таблицы?

  • Azazello
    26 Мар 2012, 15:37 г.

    Добрый день! Для Microsoft Office Excel 2003. Выделить необходимые колонки. Далее меню. Файл -> Печать -> Вывести на печать, поставить галочку на «выделенный диапазон» -> Ok. Или я неправильно вас понял?

    Если вы не хотите, чтобы Excel отображал пустые значения, тогда Сервис -> Параметры -> Вид -> Отображать, убрать галочку «нулевые значения» -> Ok.

Оставить комментарий

Вы должны войти для комментирования записи.